Internet Explorer 8

Follow

Microsoft started the development of Windows XP at the beginning of 2014. There have been no updates for Internet Explorer 8 since then. Therefore, a higher version of Internet Explorer is required in order to be able to use our portal. However, we strongly recommend not to use the Internet Explorer and to rely on other browsers such as Firefox or Google Chrome. The Internet Explorer 8 is now technically very obsolete and only partly compatible with our portal, which was developed for newer browsers.

Have more questions? Submit a request

Comments

Powered by Zendesk